В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kalmykov24
kalmykov24
27.04.2020 19:08 •  Информатика

50 ! написать программу которая просит ввести 10 чисел и находит сумму всех чисел,которые больше 0 из ряда введенных для pascal abc

Ответ:
кошка372
кошка372
07.10.2020 19:47
Program abc;
var a, summa:integer;
begin
summa:=0;
writeln('Введите 10 чисел');
for i:integer:=1 to 10 do begin
 readln(a);
if a>0 then summa:=summa+a;
end;
writeln(summa)
end.
0,0(0 оценок)
Ответ:
Асем1211
Асем1211
07.10.2020 19:47
// PascalABC.NET 3.3, сборка 1576 от 16.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
var a:= ReadArrInteger(10);
Writeln(a.Where(t->t>0).Sum);
end.
Пример:
0
12
2
3
5
6
1
2
5
6
42
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?