В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
sharapoid
sharapoid
29.10.2022 12:33 •  Информатика

Нужно написать программу на паскаль ! нужно сделать треугольник вот такой --121-- -12321- 1234231 и тд

Ответ:
monster19977s2
monster19977s2
07.10.2020 18:09
Const n=4;
var i,j:integer;
begin
for i:=1 to n do
 begin
 for j:=1 to n-i do write('-');
 for j:=1 to i do write(j);
 for j:=i-1 downto 1 do write(j);
 for j:=1 to n-i do write('-');
 writeln;
 end;
end.

Результат:
---1---
--121--
-12321-
1234321
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?