В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
niceglotatel
niceglotatel
27.03.2021 07:40 •  Информатика

На c++ напишите программу, которая находит все различные цифры в символьной строке. формат входных данных на вход программе подаётся символьная строка. формат выходных данных программа должна вывести в одной строке все различные цифры, которые встречаются в исходной строке, в порядке возрастания. если в строке нет цифр, нужно вывести слово 'no'.

Ответ:
Sausage2281
Sausage2281
07.10.2020 18:00
// Если захочешь перенести массив из глобальных переменных, не забудь обнулить его

#include <bits/stdc++.h>

using namespace std;

bool a[10];
int main()
{
  string s;
  cin >> s;
  for (int i = 0 ; i < s.length(); ++i)
    if (isdigit(s[i]))
        {
          int ind = s[i]-'0';
          a[ind] = true;
        }
  bool fl = false;
  for (int i = 0; i < 10; ++i)
    if (a[i])
      {
        fl = true;
        cout << i << ' ';
      }
if (!fl)
        cout << "NO";

}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?