В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Marina5839458593
Marina5839458593
04.09.2022 10:57 •  Информатика

Написать программу на pascal вычислить сумму квадратов вводимых чисел. числа вводятся, пока не будет нажат ноль.

Ответ:
Superpuper228911
Superpuper228911
07.10.2020 17:28
//PascalABC.NET
//Версия 3.3, сборка 1611 
begin
var a:=ReadSeqIntegerWhile(x->x<>0).ToArray();
a.Transform(x->x*x);
write(a.Sum());
end.
0,0(0 оценок)
Ответ:
sasha16971
sasha16971
07.10.2020 17:28
// PascalABC.NET 3.3, сборка 1611 от 06.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln('Сумма квадратов: ',ReadSeqIntegerWhile(t->t<>0).Select(t->t*t).Sum)
end.

Пример
16 -23 18 24 5 -12 7 11 9 5 2 0
Сумма квадратов: 2134
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?