В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Жак104
Жак104
12.01.2023 15:22 •  Информатика

Напишите программу вычисления наименьшего общего кратного в следующих четырех чисел : 36,54,18 и 15 . используйте процедуру вычисления наибольшего общего делителя двух чисел.

Ответ:
mrfreeman26p0aanr
mrfreeman26p0aanr
07.10.2020 17:25
// PascalABC.NET 3.3, сборка 1611 от 06.01.2018
// Внимание! Если программа не работает, обновите версию!

function HOK(a,b:integer):integer;
begin
  Result:=a*b;
  while b>0 do (a,b):=(b,a mod b); // a - НОД
  Result:=Result div a
end;

begin
  Writeln('НОК(36,54,18,15)=',HOK(HOK(36,54),HOK(18,15)))
end.

Результат
НОК(36,54,18,15)=540
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?