В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ngjjndnd
ngjjndnd
10.04.2020 09:05 •  Информатика

Напишите программу, которая будет выводить на экран последовательность фибоначчи. первые два члена последовательности и количество выводимых на экран членов пользователь должен ввести с клавиатуры (c++)

Ответ:
#include <iostream>
int main(){    int n;
    std::cin >> n;
    int a = 1;    int b = 1;
    for(int i = 0; i < n; i++)    {        std::cout << (i % 2 == 0 ? a : b) << std::endl;
        if(i % 2 == 0)            a += b;        else             b += a;    }
    return 0;}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?