В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
loshka2256
loshka2256
05.11.2020 07:37 •  Информатика

Написать программу с языка программирования паскаль по нахождению ответа на вопрос: войдет ли круг диаметром d в прямоугольную рамку размером а на b составить программу просто молю, скажите как решать, , желательно с подробным ! 9 класс

Ответ:
55964643
55964643
07.10.2020 16:33
Сначала задача должна быть решена геометрически. Очевидно, что круг войдет в прямоугольник если его диаметр D будет меньше, чем меньшая из сторон этого прямоугольника min(a,b). Вот и все решение.

По этому решению составляем алгоритм:
1. Ввести a, b, D
2. Найти m - минимум (a,b)
3. Если D<m, то вывести сообщение "Войдет", иначе вывести сообщение "Не войдет".
4. Завершить работу.

Осталось написать программу.

1. Современное решение

// PascalABC.NET 3.3, сборка 1611 от 06.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var (a,b,d):=ReadReal3('Введите через пробел a,b,D:');
  var m:=Min(a,b);
  if D<m then Writeln('Войдет')
  else Writeln('Не войдет')
end.

Пример
Введите через пробел a,b,D: 14.5 11 10.6
Войдет

2. "Школьный" вариант - так писали наши отцы и деды

var
  a,b,D,m:real;

begin
  Write('Введите через пробел a,b,D: ');
  Read(a,b,d);
  if a<b then m:=a
  else m:=b;
  if D<m then Writeln('Войдет')
  else Writeln('Не войдет')
end.
0,0(0 оценок)
Ответ:
megamaximvax
megamaximvax
07.10.2020 16:33
Var a,b,D:integer;
begin
readln(a,b);
readln(D);
if (D<=a) and (D<=b) then writeln('YES')
else writeln('NO');                          
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?