Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Nagornovani2002
15.10.2021 12:20 •
Информатика
Написать программу определяющую, что точка принадлежит треугольнику на языке с координаты вершин треугольника(-1; 0) (0; 1) (1; 0).
Ответ:
кококо23
07.10.2020 15:54
#include <stdio.h>
int main()
{
float x,y;
scanf("%f",&x);
scanf("%f",&y);
if (y>=0 && y<=-x+1 && y<=x+1) printf("YES");
else printf("NO");
return 0;
}
Пример:
-0.2
0.2
YES
0,0
(0 оценок)
Популярные вопросы: Информатика
bissimbayevaa
07.09.2021 04:21
С ИНФОРМАТИКОЙ Соотнеси арефметические операции ...
Малефисента1111111
07.06.2022 08:40
Помагите нужно прямо сейчасс...
Hotaru385
05.01.2021 00:01
Begin gettime(часы,минуты,секунды,миллисекунды); выполнение тестов; gettime(часы,минуты,секунды,миллисекунды); end. как узнать время выполнения тестов? т.е конечное время минус начальное....
Дима566779
05.01.2021 00:01
Реши . имеются бочка и два кувшина емкостью 3 и 8 литров. исполнитель джинн может набирать воду из реки в каждый кувшин,выливать из него воду и определять налита ли вода в кувшине...
Vladikf01Vlad220
18.04.2020 00:59
Дан массив из n натуральных чисел .определить количество элементов кратных 3 и не кратных 5...
89050864690
29.09.2020 02:10
Постройте таблицы истинности A v B & - A...
margosha2810
25.07.2021 03:49
В той из двух матриц, которая не содержит ни одного нулевого элемента, изменить её элементы путём вычитания из них среднего арифметического отрицательных элементов этой матрицы. Напишите...
Alips
29.05.2022 19:27
Диагональ экрана: 14 дюйм разрешение экрана: 1920x1080 процессор: AMD Ryzen 5 5500U видеокарта: AMD Radeon Graphics размер оперативной памяти: 8 ГБ тип жесткого диска: SSD общий объем...
gorjchevst
13.01.2021 10:48
Значение выражения: x OR y AND NOT z при x = False, y = True, z = False будет равно Выберите один ответ: a. x b. 1 c. z d. 0...
nastyaplokhovanastya
14.11.2022 15:25
Определите тип переменной е. Var c, d: integer; e: ???begine:=c+d;end....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
int main()
{
float x,y;
scanf("%f",&x);
scanf("%f",&y);
if (y>=0 && y<=-x+1 && y<=x+1) printf("YES");
else printf("NO");
return 0;
}
Пример:
-0.2
0.2
YES