Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
mulin2000462345
18.03.2020 11:56 •
Информатика
Написать программу на языке с программа должна считывать последовательность 25 чисел из файла, заменить все элементы, которые меньше среднего арифметического этих элементов, на 0 и вывести новую последовательность в новый файл
Ответ:
shyndari
07.10.2020 15:51
#include <stdio.h>
main()
{
int x, s=0, n=0;
float sr;
FILE *fin, *fout;
fin = fopen("input.txt", "r");
fout = fopen("output.txt", "w");
while (fscanf(fin, "%d", &x) == 1) {
s+=x;
n++;
}
sr = 1.0*s/n;
fclose (fin);
fin = fopen("input.txt", "r");
while (fscanf(fin, "%d", &x) == 1) {
if (x < sr) x = 0;
fprintf (fout, "%d ", x);
}
fclose (fout);
fclose (fin);
}
Пример:
Файл input.txt:
21 45 87 61 90 43 70 15 33 58
Файл output.txt:
0 0 87 61 90 0 70 0 0 58
0,0
(0 оценок)
Популярные вопросы: Информатика
23redalice11
30.03.2020 01:48
Названия программ, которых можно передавать голосовые сообщения через компьютерную сеть...
Kaaaaktuuuus
03.01.2021 11:11
Объем сообщения, содержащего 256 символов, составил 1/16 часть кбайта. каков размер алфавита, с которого записано сообщение?...
gigi81
18.05.2022 23:18
Назовите одиночные растения! надо....
toshaprostakis45
18.05.2022 23:18
Өткен аптаның сенбі, жексенбісінді біз астанаға онда жаңа, үлкен қонақұйге бөлмелеріміз шағын, бірақ болды. таңертең қонақүйде ал кешке мейрамханада сенбі күні кешке жаңа...
DianaDeli20005
18.05.2022 23:18
Найти наименьшее значение выражения. (x-4)^2-5...
mrhack711ozvry4
18.05.2022 23:18
Вычислив значение выражиния 1000х+(444 х-+353х)прих=7...
яна7933
18.05.2022 23:18
мех горностая обитающего в сибирской тайге - чистейшей белизны. когда он от преследователей и на его пути непроходимая грязная лужа, он предпочитает принять смерть,...
Асамия
18.05.2022 23:18
Попробуйте объяснить почему неизвестнвй автор выбрал для сижета не победы а позора соотечестников...
lis316721
18.05.2022 23:18
Построй график функций y=0,5x-2.найдите точки пересечения с осями координат...
Усварппоры
18.05.2022 23:18
Выведите молекулярную формулу углеводорода 92,31 % углерода и 7,69% водорода плотность 2,96 г/литр...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
main()
{
int x, s=0, n=0;
float sr;
FILE *fin, *fout;
fin = fopen("input.txt", "r");
fout = fopen("output.txt", "w");
while (fscanf(fin, "%d", &x) == 1) {
s+=x;
n++;
}
sr = 1.0*s/n;
fclose (fin);
fin = fopen("input.txt", "r");
while (fscanf(fin, "%d", &x) == 1) {
if (x < sr) x = 0;
fprintf (fout, "%d ", x);
}
fclose (fout);
fclose (fin);
}
Пример:
Файл input.txt:
21 45 87 61 90 43 70 15 33 58
Файл output.txt:
0 0 87 61 90 0 70 0 0 58