Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
shkorolewsky20
08.02.2021 23:43 •
Информатика
Написать программу на с++. написать подпрограмму, которая находит максимальную цифру заданного числа и выводит её на экран.
Ответ:
bolyubash051
07.10.2020 15:51
#include <iostream>
using namespace std;
void mxd(int n) {
int k,mx=0;
do {
k=n%10; n/=10;
if (k>mx) mx=k;
}
while (n>0);
cout<<mx<<endl;
}
int main() {
int n;
cout<<"number: "; cin>>n;
mxd(n);
system("pause");
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
m987m
23.10.2022 20:45
Вот капец я тут новенькая вот как ответить на во на знания.сом если я нажимаю, а оно не печатает если что я на компе....
Kasha26336
15.10.2022 19:19
Как войти в иженер меню самсунг а 10...
ApollaKop
14.04.2022 06:24
4. Какиетипы документов можно загружать вгугл диск, а какиесоздавать?...
Кипарисный
09.08.2020 14:06
5. как совместно использовать документовв своем облачном хранилище? которые уровни доступа можнопредоставить? 6. как создают о с для чего используют электронной закладки...
Страус123552
13.02.2020 06:12
Пользователь выводит с клавиатуры числа P - первый член прогрессии, R -разность прогрессии и число N. Написать программу которая выводит на экран суммы членов арифметической...
MrDog2005
03.08.2020 07:17
Имеется садовый участок, имеющий форму прямоугольника со сторонами А метров и В метров. Составьте алгоритм и программу, которая определить сколько досок надо купить,...
сонякласс17171717
10.12.2022 02:12
Если количество выполнений тела цикла неизвестно, то какой вид цикла не возможен: Укажите правильный вариант ответа: Цикл while Цикл repeat Цикл for...
Kamila2o18
01.01.2020 02:16
5. які рівні доступу можна надати до документів у своєму хмарному сховищі?...
PaleMan2014
11.12.2022 00:17
В игре stars wars jedi fallen order как сделать захват цели на компе напишите детально...
polikzaisheva12
20.06.2020 07:51
У исполнителя омега две команды,которым присвоены номера: 1.прибавь 1 2.припиши справа b Программа 12221 переводит число 5 в число 6556 ,определите значение b...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
using namespace std;
void mxd(int n) {
int k,mx=0;
do {
k=n%10; n/=10;
if (k>mx) mx=k;
}
while (n>0);
cout<<mx<<endl;
}
int main() {
int n;
cout<<"number: "; cin>>n;
mxd(n);
system("pause");
return 0;
}