В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Составьте программу, котоая печатает слово true, если указанное высказываени является истинным, и false в противном случае цифры исходного четырехзначного числа n образуют строго возрастающую последовательность входные данные на вход подается число n (1000< =n< =9999) выходные данные true - если все цифры числа образуют строго возрастающую последовательность false - в противном случае пример: вход: 1234 вывод: true пример: вход: 1224 вывод: false вот моя программа { int n, a, b, c, d; scanf("%d",& n); a=n%10; b=n/10%10; c=n/100%10; d=n/1000; if ( b==a+1 & & c==a+2 & & d==a+3) printf("true"); else printf("false"); } в любом случае выводит фолс

Ответ:
Катюшенька1601
Катюшенька1601
26.08.2020 20:53
if ( b==a+1 && c==a+2 && d==a+3) printf("true");

заменить на следующий

if ((a>b) && (b>c) && (c>d)) printf("true");
0,0(0 оценок)
Ответ:
jessikafox
jessikafox
26.08.2020 20:53
ОТДЕЛ Задание+;
ИСПОЛЬЗУЕТ Вывод ИЗ "...\Отделы\Обмен\", Приём ИЗ "...\Отделы\Обмен\";

ПЕР
  число: ЦЕЛ;

УКАЗ
  число := Приём.Число(); Вывод.Цепь("^");
  ЕСЛИ
    число ДЕЛИТЬ 1000 < число ДЕЛИТЬ 100 ОСТАТОК 10 И
    число ДЕЛИТЬ 100 ОСТАТОК 10 < число ДЕЛИТЬ 10 ОСТАТОК 10 И
    число ДЕЛИТЬ 10 ОСТАТОК 10 < число ОСТАТОК 10
  ТО
    Вывод.Цепь("труе")
  ИНАЧЕ
    Вывод.Цепь("фалсе")
  КОН

КОН Задание.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?