Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
ScRoller
14.10.2020 02:24 •
Информатика
Составить программу, которая заполняет массив, сортирует по убыванию, находит максимум м выводит его до и после сортировки.
Ответ:
Алекс2241
07.10.2020 15:14
// PascalABC.NET 3.3, сборка 1599 от 17.12.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
a:=a.OrderByDescending(t->t).ToArray; a.Println;
Writeln('Максимум: ',a.First);
end.
Пример
n= 15
22 26 18 -12 44 44 44 50 -30 11 6 8 -22 2 25
50 44 44 44 26 25 22 18 11 8 6 2 -12 -22 -30
Максимум: 50
0,0
(0 оценок)
Популярные вопросы: Информатика
SofyaA3
13.11.2022 04:29
Кокие есть Программы страницэто во по книге 7 класса информатика стр 66...
pharaohandtrasher
20.09.2021 11:51
Определите значения переменных x и y после выполнения фрагмента алгоритма:x := 11;y := 3;x := x mod 3 + y div 2;y := x + y;Нужен только ОТВЕТ...
Mari2909
08.10.2020 03:02
Реши . для кабинета информатики нужно 11 компьютеров. для кабинета начальных классов нужно 36 одноместных парт. для кабинета нужна 1 доска. для кабинета биологии нужно...
ЮраУтюг
01.08.2021 21:17
Зачем нужно лицензионное соглашение ? ...
sobakazabiyaka
03.05.2023 00:14
При интернет-соединении с максимальной скоростью передачи данных 192 кбит/с аудиофайл размером 3600 кбайт будет в лучшем случае передаваться: а) 5 минб) больше 15 минв)...
Kramar1
14.05.2023 20:06
Сложиться до 10. пользователь вводит целые числа, ноль — сигнал остановки. гарантируется, что в какой-то момент сумма введённых чисел окажется равной 10. программа...
ДобродушныйЕнот
12.04.2023 16:00
Переведите из десятичной системы в двоичную: 692...
bikimbetovadarina
12.04.2023 16:00
После перекодировки текстового сообщения, записано в 16 битном коде unicode, в 8 битную кодировку кои-8 информационный объём сообщения уменьшился на 1 кб. сколько символов...
VERONIKA114561378
12.04.2023 16:00
Переведите из двоичной системы в десятичную: 1000010011...
dashashubina55
06.02.2020 01:44
Напишите, диолог о летних каникулах простой на с переводом...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
a:=a.OrderByDescending(t->t).ToArray; a.Println;
Writeln('Максимум: ',a.First);
end.
Пример
n= 15
22 26 18 -12 44 44 44 50 -30 11 6 8 -22 2 25
50 44 44 44 26 25 22 18 11 8 6 2 -12 -22 -30
Максимум: 50