В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
safeer
safeer
13.10.2021 16:55 •  Информатика

Составить программу , которая в одномерном массиве размерностью 14 ( элементами являются случайные числа от 10 до 99) находит наименьший элемент оканчивающихся на 1.

Ответ:
bogahewa78
bogahewa78
07.10.2020 14:29
// PascalABC.NET 3.3, сборка 1599 от 17.12.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(14,10,99); a.Println;
  var s:=a.Where(x->x mod 10=1);
  if s.Count=0 then Writeln('Нет элементов, оканчивающихся на 1')
  else Writeln('Наименьший элемент, оканчивающийся на 1: ',s.Min)
end.

Пример
34 32 61 31 56 42 23 89 10 25 59 15 60 73
Наименьший элемент, оканчивающийся на 1: 31

Составить программу , которая в одномерном массиве размерностью 14 ( элементами являются случайные ч
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?