В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Напишите программу. определить номер подъезда и этаж квартиры по её номеру, если известна этажность дома и количество квартир на лестничной площадке

Ответ:
dulikosha20051
dulikosha20051
07.10.2020 14:01
Program P1;
var z,x,y,p,e:integer;
begin
  write('Количество этажей = '); readln(x);
  write('Количество квартир на лестничной площадке = ');
  readln(y);
  write('Номер квартиры = '); readln(z);
  p:=(z-1) div (x*y)+1;
  e:=((z-(p-1)*x*y)-1) div y +1;
  writeln('Квартира ',z,' находится в ',p,' подъезде на ',e,' этаже');
end.

Пример:
Количество этажей = 9
Количество квартир на лестничной площадке = 4
Номер квартиры = 67
Квартира 67 находится в 2 подъезде на 8 этаже
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?