В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
sashacom13
sashacom13
24.08.2021 00:12 •  Информатика

Составьте программу которая заполняет массив b 1..8 случайными целыми числами в диапозоне от 1 до 10 затем изменяет знак элементов с чётными индексами на противоположный. выведите на экран исходный и полученный массивы

Ответ:
gghvagsh167
gghvagsh167
07.10.2020 13:54
Var
  b: array[1..8] of integer;
  i: byte;
begin
  randomize;
  writeln('Исходный массив.');
  for i := 1 to 8 do
  begin
    b[i] := random(9)+1;
    write(b[i], ' ');
  end;
  writeln;
  writeln('Измененый массив.');
  for i := 1 to 8 do
  begin
    if i mod 2 = 0 then b[i] := -b[i];
    write(b[i], ' ');
  end;
  writeln;
end. 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?