В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
GoldGriffon
GoldGriffon
05.03.2023 21:44 •  Информатика

Нужно написать программу на c (ну или хотя бы на c++)‼️‼️‼️‼️‼️‼️‼️ дана строка символов, состоящая из произвольного текста,слова разделены пробелами.вывести на экран порядковый номер слова, накрывающего к-ю.(если на k-ю позицию попадает пробел, то гомер предыдущего слова)

Ответ:
evasyperandreev
evasyperandreev
07.10.2020 13:51
#include <iostream>using namespace std; int main(){     char str [] = "dd yhd yw dcjkayt dvqv auyj fbajk dyusdv sddw";     int k = 9; //position     int before=  0, after = 0, space = 0;                         for(int i = 0; i <= k; i++){             if(str[i] == ' '){                 space++;             }         }         if(str[k] != ' '){       for(int i = k + 1; str[i]; i++){         if(str[i] == ' ' || str[i] == '\0'){             after = i;                         break;                 }         }         for(int j = k - 1; j >= 0; j--){         if(str[j] == ' ' || j == 0){             before = j;                         break;                 }     }         cout<<space + 1<<" slovo ";         for(int i = before; i < after; i++)         cout<<str[i];         }         else cout<<space<<" slovo"; return 0; }
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?