Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Angela11001
11.05.2021 18:43 •
Информатика
Написать программу. в массиве заполненном случайными числами с(10) найти сумму чисел, которые равны 10. вывести сумму на экран.
Ответ:
shahboz3
07.10.2020 13:20
#include <iostream>
#include <ctime>
#include <algorithm>
#include <cstdlib>
#include <vector>
using namespace std;
int main() {
srand(time(0));
vector <int> a;
int i,s=0;
for(i=0;i<10;i++)
a.push_back(rand() % 11);
sort(a.begin(),a.end());
for (i=0;i<10;i++){
if(a[i]==10)
s=s+10;
}
cout<<s;
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
Dashatatur1
04.01.2021 05:01
2. Заполни таблицу Поколения компьютеров Дата создания Элементная база компьютера Компьютеры первого поколения Компьютеры второго поколения Компьютеры третьего поколения Компьютеры...
DeRellik
26.01.2023 03:52
Как вернуть действие назад в Adobe After Effects? Или Удалить фото или видео...
lizawera
10.01.2022 21:04
1. с клавиатуры вводится целое положительное (может быть равно 0) число а, не превышающее 30 000. напиши программу, которая считает и выводит на экран сумму цифр числа а....
alis2710p00nvt
01.12.2022 01:05
Сколько дюймов в 25 точках (pt)? (ответ округли до сотых!)...
Timurrovt456
26.07.2021 17:35
Расположите в порядке возрастания числа A=4D16, B=10010112, C=1148 (в решении показываем перевод каждого числа)...
Xenia2005
09.11.2020 18:16
Задача на программирование: Создать программу, сравнивающую значение переменных x1 и x2. Если x1 x2 - вывести на экран сообщение «Больше», если меньше или равно – вывести...
Nastiya320
18.11.2021 04:48
Дано изображение высотой 256 точек с глубиной цвета 16 бит, которое хранится в виде файла размером 180 кбайт. Определите ширину изображения...
EvaPark1997
26.03.2023 01:36
Перевести формулу на язык Паскаль Y=√ln(x^3)-4x (Корень захватывает всю формулу )...
Даша182005
08.05.2021 23:15
Найдите корень уровнения (5x++14)=9...
дэн247
08.05.2021 23:15
Установите последовательность процессов, происходящих при размножении и развитии цветковых растений, начиная с момента формирования пыльцы. запишите соответствующую последовательность...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
#include <ctime>
#include <algorithm>
#include <cstdlib>
#include <vector>
using namespace std;
int main() {
srand(time(0));
vector <int> a;
int i,s=0;
for(i=0;i<10;i++)
a.push_back(rand() % 11);
sort(a.begin(),a.end());
for (i=0;i<10;i++){
if(a[i]==10)
s=s+10;
}
cout<<s;
return 0;
}