В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
gurova07
gurova07
03.02.2022 23:04 •  Информатика

Составьте программу вычисление тех значений элементов массива которые меньше 16

Ответ:
Помогите111234
Помогите111234
07.10.2020 12:05
Const n=10; 
var a:array[1..n] of integer;
i,k:integer; 
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
 begin
 a[i]:=random(31);
 write(a[i]:4);
 end;
writeln;
k:=0;
for i:=1 to n do
 if a[i]<16 then k:=k+1;
writeln('Количество элементов массива < 16 = ',k);
end.

Пример:
Массив A:
17 28 18 19 12 9 24 6 18 12
Количество элементов массива < 16 = 4
0,0(0 оценок)
Ответ:
axieva35
axieva35
07.10.2020 12:05
Const m=200;
var a: array[1..m] of integer;
    i,n: integer;
begin
   write('количество элементов массива:  ');
   readln(n);
   randomize;
   write('массив:  ');
   for i:=1 to n do
   begin
     a[i]:=random(40);
     write(a[i],' ');
   end;
   writeln;
   write('элементы, меньшие 16:  ');  
   for i:=1 to n do if a[i]<16 then
     write(a[i],' ');
end.

количество элементов массива:  15
массив:  6 22 28 39 24 3 19 15 35 22 2 2 22 1 32 
элементы, меньшие 16:  6 3 15 2 2 1 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?