В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
lenyskadi
lenyskadi
04.08.2021 08:19 •  Информатика

Составить программу, которая получает новую строку, удалив из первоначальной строки третье слово

Ответ:
УмнаяДебилка
УмнаяДебилка
07.10.2020 11:43
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadlnString.ToWords; // читаем строку, образуем массив слов
  var s:=(a[:2]+a[3:]).JoinIntoString; // получаем новую строку
  Writeln(s) // вывод...
end.

Пояснения.
a - массив с индексами от 0 до n-1, где n - число слов.
Срез a[:2] возвращает последовательность элементов массива 0 и 1.
Срез a[3:] возвращает последовательность элементов массива, начиная с третьего и до конца массива. Объединение последовательностей порождает необходимый набор слов, который объединяется в строку через пробел при

Пример
А роза упала на лапу Азора
А роза на лапу Азора
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?