В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
rostikstorozhev
rostikstorozhev
15.10.2020 17:06 •  Информатика

Написать программу на с++. знайти максимальний елемент у третьому рядку матриці р(5,5) і його індекс. значение масивив задаеться довильно.

Ответ:
#include <iostream>
using namespace std;

int main() {
    const int n=5;
    int p[n][n];
    srand(time(NULL));
    cout << "Матрица:\n";
    for(int i = 0; i < n; i++){
    for(int j = 0; j < n; j++){
    p[i][j]=rand() % 50;
    cout << p[i][j] << " ";
    }
    cout << "\n";
    }
    int max = p[2][0], jmax=0;
    for(int j = 1;  j<n; j++)
        if (p[2][j]>max) {
        max = p[2][j]; jmax = j;
        }
    cout << "max = p[3,"<<jmax+1<<"] = "<<p[2][jmax]<<"\n";
}

Пример:
Матрица:
33 28 18 49 22
9 43 6 18 37
2 25 8 36 21
29 6 1 35 5
46 23 42 27 46
max = p[3,4] = 36
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?