В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ap1611341
ap1611341
11.06.2021 16:44 •  Информатика

Составить программу на языке pascal: решить квадратное уравнение вида а*х*х+в*х+с=о для произвольных а, в, с.

Ответ:
fedushkinmax
fedushkinmax
07.10.2020 11:38
Текст плохо форматируется, поэтому скину файлом.
0,0(0 оценок)
Ответ:
Zadrot233
Zadrot233
07.10.2020 11:38
//Pascal
var
  a, b, c, d, x1, x2: real;
begin
  write('Введите a = '); readln(a);
  write('Введите b = '); readln(b);
  write('Введите c = '); readln(c);
  if ((a = 0) and (b = 0) and (c = 0)) then
    writeln('X любое')
  else
  if a <> 0 then
  begin
       d := sqr(b) - 4 * a * c;
       if (d > 0) then
       begin
            x1 := (-b+sqrt(d))/(2*a);
            x2 := (-b-sqrt(d))/(2*a);
            writeln('x1 = ', x1);
            writeln('x2 = ', x2);
       end
       else
       if d = 0 then
       begin
            x1:=-b/(2*a);
            x2:=x1;
            writeln('x1 = ', x1);
            //writeln('x2 = ', x2);
       end
       else
       if d < 0 then
          writeln('Корней нет.');
  end
  else
  if (a = 0) and (b = 0) then
    writeln('Решений нет.')
  else
  if (a = 0) then
  begin
    x1 := (-c)/b;
    writeln('x = ', x1);
  end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?