В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
didlok
didlok
30.03.2020 04:00 •  Информатика

10. напишите программу: "склавиатуры вводится строка из двух слов. вывести н экран: a) первую и последнюю буквы второго слова; б) количество букв второго слова; в) количество глассных (a) в строке.все это должно быть в одной программе

Ответ:
bezrodnayamila
bezrodnayamila
07.10.2020 11:36
Var s: string;
    n,k: integer;
begin
   write('строка: ');  readln(s);
   n:=pos(' ',s);
   if n>0 then 
   begin
     writeln('первая буква второго слова: ',s[n+1]);
     writeln('последняя буква:  ',s[length(s)]);
     writeln('количество букв:  ',length(s)-n);
     k:=0; 
     for n:=1 to length(s) do 
     if s[n]='a' then k:=k+1;
     if k>0 then writeln('количество букв a: ',k)
     else writeln('в строке нет буквы a');
   end
   else writeln('в строке одно слово');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?