В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Чевапчичи
Чевапчичи
06.08.2021 22:32 •  Информатика

Написать программу замещения первой половины строки второй а второй первой в с++

Ответ:
45757858ЫфыРф
45757858ЫфыРф
07.10.2020 11:19
#include <iostream>
#include <string>

using namespace std;

int main()
{
    string a;
    char temp;
    cin >> a;
    for (int i = 0; i < a.size() / 2; ++i) {
        temp = a[i];
        a[i] = a[a.size() / 2 + i];
        a[a.size() / 2 + i] = temp;
    }
    cout << a;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?