В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
maryvysotinap08vi8
maryvysotinap08vi8
20.05.2020 05:25 •  Информатика

45 . составить программу, которая выводит на экран сумму, произведение и среднее арифметическое кубов всех целых чисел от a до b. (значение переменных a и b вводятся с клавиатуры).

Ответ:
amir158
amir158
07.10.2020 10:46
program sdad; var a, b, i, c: integer; sum, pro, sr: real; begin sum := 0; pro := 1; sr := 0; c := 0; readln(a, b); for i := a to b do begin c := c + 1; sum := sum + i; pro := pro * i; sr := sr + i * i; end; sr := sr / c; writeln('Сумма чисел = ', sum); writeln('Произведение чисел = ', pro); writeln('Среднее арифметическое кубов = ', sr); end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?