В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Дан массив из 10 элементов. составить программу которая даёт ответ на вопрос есть ли в массиве более одного элемента равного максимальному. ответ выводится в виде да/нет. pascal.

Ответ:
perov200
perov200
07.10.2020 10:28
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(10,1,9); a.Println;
  if a.Where(t->t=a.Max).Count>1 then
    Writeln('Есть элементы, равные максимальному')
  else
    Writeln('Нет элементов, равных максимальному')
end.

Примеры
5 5 6 4 4 1 6 9 8 3
Нет элементов, равных максимальному

1 8 1 5 2 3 1 4 5 8
Есть элементы, равные максимальному
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?