Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
romchik238
11.10.2020 08:40 •
Информатика
Составить программу в паскаль. дана последовательность из 10 чисел (2,3,-15,4.4,0,-3.2,3,25,-5,0). найти произведение положительных элементов и количество отрицательных элементов.
Ответ:
lizadexx
07.10.2020 10:23
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=Arr(2.0,3.0,-15.0,4.4,0.0,-3.2,3.0,25.0,-5.0,0.0);
a.Println;
Writeln('Произведение положительных= ',
a.Where(t->t>0).Aggregate(1.0,(x,y)->x*y));
Writeln('Количество отрицательных= ',a.Where(t->t<0).Count)
end.
Результат
2 3 -15 4.4 0 -3.2 3 25 -5 0
Произведение положительных= 1980
Количество отрицательных= 3
0,0
(0 оценок)
Популярные вопросы: Информатика
Xessiafel
16.02.2022 08:44
Pascal abc составить программу перевода денежных единиц из рублей в доллары и евро, если известен курс этих валют....
Usdied
16.02.2022 08:44
Животные также получают информацию с своих органов чувств, но значимость того или иного органа чувств для разных животных различн. какое, по вашему мнению,чувство (зрение,слух,обоняние,осязание)является...
Лена200115
25.03.2020 00:44
ответить на во по информатике ...
MDMOD1
30.05.2022 22:56
Дописати рівняння, урівняти методом електронного балансу 1) Ca(NO3)2-t°-2) Hg(NO3)2-t-...
nik480
01.07.2022 22:15
Розв язати рівняння 5·(х - 3) -12 = 7·(-х - 13) + 16. Введіть у поле тільки число, що є розв язком рівняння (без букви х):...
iNNA9078
07.03.2020 07:36
мәтін не туралы екенің анықта ...
KyroSC
18.01.2020 23:44
Урок 2 Составление меню. Урок 2Выбери информацию, относящуюся к основам рационального питания.Ню.Верных ответов: 2употребление пищи в небольших количествахпреимущества калорийностииспользование...
АминаКамалиева1
06.10.2021 07:39
Упражнение 1. Укажите, в каких словах все буквы выступают в главном значении? А. общежитие; Б. колесо; В. сырный; Г. медицинское; Д. небосклон; Е. солнце; Ж. сынок; з.луна...
polina198678
15.06.2022 21:37
В якому році Й. Гутенберг винайшов іб друкування?...
petrosiannikita
15.06.2022 21:37
Сноски. Урок 2 Изучи предложенное изображение и определи количество элементов группы «Названия» вкладки меню «Ссылки». .(...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// Внимание! Если программа не работает, обновите версию!
begin
var a:=Arr(2.0,3.0,-15.0,4.4,0.0,-3.2,3.0,25.0,-5.0,0.0);
a.Println;
Writeln('Произведение положительных= ',
a.Where(t->t>0).Aggregate(1.0,(x,y)->x*y));
Writeln('Количество отрицательных= ',a.Where(t->t<0).Count)
end.
Результат
2 3 -15 4.4 0 -3.2 3 25 -5 0
Произведение положительных= 1980
Количество отрицательных= 3