Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
danlis2003
22.11.2021 05:25 •
Информатика
Впаскале. даны три числа, требуется найти среднее из них. средним назовем число, которое больше наименьшего из данных чисел, но меньше наибольшего.
Ответ:
простоникр
07.10.2020 10:32
Var a,b,c,mi: integer;begin
readln (a,b,c);
if ((b>a) and (b<c)) or ((b>c) and (b<a)) then mi:=b;
if ((a>b) and (a<c)) or ((a<b) and (a>c)) then mi:=a;
if ((c>a) and (c<b)) or ((c<a) and (c>b)) then mi:=c;
write (mi);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Varya1111111111113
23.12.2021 09:24
Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. если первое число четно, то выведите сумму этих четырех чисел. если...
Maximoniko
09.06.2023 10:04
Напишите код буду очень благодарен...
delvar25
24.08.2020 18:49
Сколько единиц в двоичной записи восьмеричного числа 1731₈...
neondragooffi
24.08.2020 18:49
Количество входящих в алфавит символов (знаков), называется...
Димон123467
20.02.2021 17:39
Раскрась шарики так чтобы Красный шарик был больше жёлтого шарика но меньше зеленого...
qpwo
20.02.2021 17:39
Найдите художественно-выразительные средства, обоснуйте их роль в стихотворении. Рубцов Оттепель Нахмуренное, с прозеленью, небо, Во мгле, как декорации, дома, Асфальт и...
burmistrowkiri
18.04.2022 14:50
9.Отметьте причины и условия создания единого государства, укажите правильные номера: 1)необходимость контролировать торговые пути; 2)необходимость борьбы с Ордой; 3)возрождение...
saimon0
31.05.2021 18:38
решить задания под галочкой!...
СерегаБатя
31.05.2021 18:38
Найдите в тексте и запишите описание кибернетического мальчика. Как он выглядел? С каких частей речи автор описал внешность Электроника? ...
zelenskiy10000
31.05.2021 18:38
Какие карты надо использовать при описании швеции...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
readln (a,b,c);
if ((b>a) and (b<c)) or ((b>c) and (b<a)) then mi:=b;
if ((a>b) and (a<c)) or ((a<b) and (a>c)) then mi:=a;
if ((c>a) and (c<b)) or ((c<a) and (c>b)) then mi:=c;
write (mi);
end.