В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Aksa2101
Aksa2101
24.01.2023 13:53 •  Информатика

Ине нужно писать просто так, только программу. массив из 8 элементов содержит оценки за четверть. заполнение его организовать с клавиатуры. написать программу, которая вычислит четвертную оценку и выведет ее на экран. для этого будет необходимо: 1. найти сумму элементов массива. 2. посчитать среднее арифметическое оценок – x. 3. округлить х до отметки. правило, как выставляются оценки за четверть: 0

Ответ:
Spin4ik
Spin4ik
07.10.2020 10:20
Var
s, i: integer;
x:real;
mas: array [1..8] of integer;
begin
s:=0;
for i:=1 to 8 do
begin
readln (mas[i]);
s:=s+mas[i];
end;
x:=s/8;
If (x>0) and (x<2.49) then write ('2');
If (x>=2.5) and (x<=3.49) then write ('3');
If (x>=3.5) and (x<=4.49) then write ('4');
If (x>=4.5) and (x<=5) then write ('5');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?