В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Missura2001
Missura2001
30.03.2022 23:54 •  Информатика

Составить программу на паскале.двумерный массив а[4; 4] заполнен случайными числами.посчитать сумму элементов каждой строки с процедуры.

Ответ:
diankaZe
diankaZe
07.10.2020 10:09
Const n=4;
var 
a:array[1..n,1..n] of integer;
i,j,s:integer;
procedure sum(k:integer; var s:integer);
var j:integer;
begin
s:=0;
for j:=1 to n do s:=s+a[k,j];
end;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
 begin
 for j:=1 to n do
  begin
   a[i,j]:=random(100);
   write(a[i,j]:4);
  end;
  writeln;
 end;
for i:=1 to n do
 begin
 write(i,'-я строка: ');
 sum(i,s);
 writeln('s = ',s);
 end;
end.

Пример:
Исходный массив:
60 78 10 51
65 90 65 24
35 97 6 91
10 95 35 15
1-я строка: s = 199
2-я строка: s = 244
3-я строка: s = 229
4-я строка: s = 155
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?