Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
БеллаСAT
09.04.2022 10:03 •
Информатика
Вмассиве 8 элементов напишите программу которая находит сумму положительнух чмсел и кол во чисел =0
Ответ:
holzchen
07.10.2020 10:07
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(8,-9,9); a.Println;
Writeln('Сумма положительных ',a.Where(t->t>0).Sum);
Writeln('Количество нулей ',a.Where(t->t=0).Count)
end.
Пример
2 6 -6 7 0 2 3 6
Сумма положительных 26
Количество нулей 1
0,0
(0 оценок)
Популярные вопросы: Информатика
Slidopit
18.10.2021 14:05
Постройте дерево Хаффмана для любых двух фраз из списка ниже: 1) Не руби дрова на траве двора. 2) Прецедент с претендентом. 3) Течёт речка, печёт печка. Покажите полное решение....
Влад00811
30.12.2022 21:15
Приведите свой примеры профессий в которых основным види видах деятельности является основная работа с информацией...
filysh74
01.04.2023 07:51
Какие параметры могут быть у команд Рисователя...
05NARIMAN05
06.10.2022 00:44
ИНФОРМАТИКА 8 КЛАСС Написати програму, що дозволяе ввести Х-кількість хвилин та визначити, скільки в Х хвилинах секунд....
anara01051979
03.03.2023 19:15
Какие существуют типы переменных у чисел (выбрать несколько вариантов): * A. float B. list D. int E. integer C. num...
Yury28
07.03.2021 15:25
Дано: а || b, угол 1 в 7 раз меньше угла 2 Найти угол 3Дано:q || zУгол 1=35 градусов Найти:угол 3, 2,4...
daniil2003m
16.11.2020 20:24
1.Сторони трикутника дорівнюють 8 см, 9 см, 16 см. Знайдіть периметр подібного йому трикутника, якщо його найбільша сторона дорівнює 4 см.? 2.При паралельному переносi точка А(2;-1)...
мария2081
03.05.2020 20:16
219. Догадайтесь, какие согласные нужно дописать. Составьте и запишите два предложения. Осен..ий сум..а пасажир рас..вет кас..а ОКОН..ый...
Lsjsjajj
23.01.2022 23:34
Троянская война троянское царство были ли у них союзники?...
lizas7777
27.01.2022 21:35
Визначте середню добову температуру повітря, використовуючи слідуючі дані: +6oС, +8 oС, +11oС, +15 oС, +18 oС,+22 oС, +19 oС...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(8,-9,9); a.Println;
Writeln('Сумма положительных ',a.Where(t->t>0).Sum);
Writeln('Количество нулей ',a.Where(t->t=0).Count)
end.
Пример
2 6 -6 7 0 2 3 6
Сумма положительных 26
Количество нулей 1