В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ваниль2003
ваниль2003
28.03.2021 05:26 •  Информатика

Составить программу вычисления выражения: max(x^2+y^3, y^2+z^3)-4

Ответ:
RuStAm09
RuStAm09
10.09.2020 07:19
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var (x,y,z):=ReadReal3('Введите x,y,z:');
  Writeln(Max(x*x+y*y*y,y*y+z*z*z)-4)
end.

Пример
Введите x,y,z: 2.6 -1.05 4
61.1025
0,0(0 оценок)
Ответ:
маша2750
маша2750
10.09.2020 07:19
If (x+2*y) > (y*3*z-4*x) then max := (x+2*y) else max := (y*3*z-4*x);
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?