В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ТКУиК9ks11
ТКУиК9ks11
23.08.2022 16:10 •  Информатика

Написать программу: с клавиатуры вводится четырехзначное целое число. вывести на экран сообщение о соотношении суммы крайних цифр и суммы средних цифр этого числа (меньше, больше или равны).

Ответ:
chuksin2008
chuksin2008
16.08.2020 14:47
Var a,a1,a2,a3,a4,s1,s2:integer;
begin
readln(a);
a1:=a div 1000;
a2:=a div 100 mod 10;
a3:=a mod 100 div 10;
a4:=a mod 10;
s1:=a1+a4; s2:=a2+a3;
if s1>s2 then writeln(s1,' > ',s2)
 else if s1<s2 then writeln(s1,' < ',s2)
  else writeln(s1,' = ',s2);
end.

Пример:
4382
6 < 11
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?