В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Найти первый отрицательный элемент массива с цикла с постусловием repeat < тело > until < условие > напишите программу на паскале

Ответ:
LoliPeen
LoliPeen
07.10.2020 09:41
Const n=10;
var a:array[1..n] of integer;
i: integer; 
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
 begin
 a[i]:=random(41)-20;
 write(a[i]:4);
 end;
writeln;
i:=0;
repeat
i:=i+1;
until (i>=n)or(a[i]<0);
if a[i]>=0 then writeln('Нет отрицательных элементов')
else writeln('Первый отрицательный элемент = a[',i,'] = ',a[i]);
end.

Пример:
Массив A:
   8   7   0  18 -13  -9   6 -16 -13  -2
Первый отрицательный элемент = a[5] = -13
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?