Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
vika3475
17.09.2020 14:24 •
Информатика
Составьте программу которая формирует массив из 16 случайных чисел от -20 до 20 и подсчитывает количество отрицацельных элементов
Ответ:
vitaming
07.10.2020 09:39
1)
const n=16;
var a:array[1..n] of integer;
i,k:integer;
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
begin
a[i]:=random(41)-20;
write(a[i]:4);
end;
writeln;
k:=0;
for i:=1 to n do
if a[i]<0 then k:=k+1;
writeln('k = ',k);
end.
Пример:
Массив A:
-14 -7 -20 -3 12 9 -5 -4 7 11 -14 7 6 13 10 12
k = 7
2)
begin
var a:=ArrRandom(16,-20,20); a.Println;
var k:=a.Where(x->(x<0)).Count;
writeln('k = ',k);
end.
Пример:
7 9 -12 12 -7 -14 -16 15 18 -8 -5 -11 1 19 11 5
k = 7
0,0
(0 оценок)
Популярные вопросы: Информатика
ИлонаУстюгова12
04.04.2022 10:47
Подсчитайте, сколько среди данных n чисел нулей, положительных чисел, отрицательных чисел. вводится число n, а затем n чисел. необходимо вывести сначала число нулей,...
Zoi568
14.11.2021 18:30
Дано слово . проверить является ли оно перевертышем (перевертышем называется слово ,читаемое одинакого как с начала так и с конца ),...
Мирэя
27.01.2020 05:20
Дано слово s1.получить слово s2, образованное нечетными буквами слова s1....
dhhfdghgxdyhfdfcc
27.01.2020 05:20
(паскаль) написать программу пересчета веса из фунтов в килограммы (1 российский фунт равен 409,5 г). ниже представлен рекомендуемый вид экрана во время работы программы...
Danilfaha
20.04.2021 03:35
Как составить программу решения квадратного уравнения a[tex] a x^{2} + bx + c=0...
ПолинаПадафет15
20.04.2021 03:35
Устройство ввода,используемое для компьютером во время игры? другое название жёсткого диска?...
неудачник16
20.04.2021 03:35
Найти сумму s и произведение p: а) четных чисел от 1 до n б) нечетных чисел от 1 до n в) чисел, кратных 3, от 1 до n. нужно написать программу в visualstudio...
sashachadaev
20.04.2021 03:35
Алфавит состоит из 35 букв. какое кол во информации несет текст, содержащий 10 символов...
Лизок070707
06.04.2020 19:35
Напишите программу, читающую две строки и сообщающую, равны ли они. В противном случае программа сообщает, которая из них больше. Затем измените программу так, чтобы...
vika23562
30.11.2022 16:03
Замените словосочетание пироги с рыбой построенное на основе ...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
const n=16;
var a:array[1..n] of integer;
i,k:integer;
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
begin
a[i]:=random(41)-20;
write(a[i]:4);
end;
writeln;
k:=0;
for i:=1 to n do
if a[i]<0 then k:=k+1;
writeln('k = ',k);
end.
Пример:
Массив A:
-14 -7 -20 -3 12 9 -5 -4 7 11 -14 7 6 13 10 12
k = 7
2)
begin
var a:=ArrRandom(16,-20,20); a.Println;
var k:=a.Where(x->(x<0)).Count;
writeln('k = ',k);
end.
Пример:
7 9 -12 12 -7 -14 -16 15 18 -8 -5 -11 1 19 11 5
k = 7