В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kkmla123
kkmla123
14.04.2020 18:26 •  Информатика

"дана строка символов t. напишите программу, которая добавит перед и после каждой гласной буквой строки – букву ‘p’. например, ‘corectitudine’ станет ‘’. "написать на c++

Ответ:
СашаСтоляров1
СашаСтоляров1
07.10.2020 09:17
#include <iostream>
#include <set>
 
using namespace std;
int main()
{
 string t, s="";
 cout << "t = ", cin >> t, cout << endl;
 set<char> a = {'a','e','i','o','u','y'};
 for(int i=0; i<t.length(); i++)
  if(a.find(t[i]) == a.end()) s = s+t[i];
  else s = s+'p'+t[i]+'p';
 cout << s << endl;
 return 0;
}

Пример:
t = corectitudine
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?