В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
viktoria168
viktoria168
12.08.2021 18:20 •  Информатика

Составить программу для вычисления суммы факториалов всех четных чисел от m до n.(matlab)

Ответ:
pershinspa
pershinspa
07.10.2020 09:04
Var
 i,m,n,s:integer;

function fact(a:integer):integer;
var l:integer;
begin
 l:=1;
 for i:=2 to a do
 l:=l*i;
 fact:=l;
end;

begin
 read(m);
 readln(n);
 s:=0;
 for i:=m to n do
  if i mod 2=0
   then s:=fact(i)+s;
 writeln('Suma: ',s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?