В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
DarkGay
DarkGay
20.05.2022 14:15 •  Информатика

напишите программу на паскале! разработайте программу, которая строит таблицу значений функции y=(ln x)/tg x при заданных диапазоне [a, b] изменения x и шаге h. если значение функции в очередной точке не существует, то в соответствующей строке таблицы выведите сообщение «значение не существует».

Ответ:
аленаzm
аленаzm
07.10.2020 08:49
// PascalABC.NET 3.3, сборка 1583 от 25.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var (a,b,h):=ReadReal3('Введите границы и шаг табуляции:');
  if a>b then Swap(a,b); // если перепутали границы
  var x:=a;
  while x<=b+h/2 do begin
    Write(x:10:5);
    var y:=Ln(x)/Tan(x);
    if real.IsNaN(y) or real.IsInfinity(y) then
      Writeln('       значение не существует')
    else Writeln(y:15:5);
    x+=h
    end
end.

Примеры
Введите границы и шаг табуляции: -5 5 1
  -5.00000       значение не существует
  -4.00000       значение не существует
  -3.00000       значение не существует
  -2.00000       значение не существует
  -1.00000       значение не существует
   0.00000       значение не существует
   1.00000        0.00000
   2.00000       -0.31722
   3.00000       -7.70704
   4.00000        1.19733
   5.00000       -0.47609

Введите границы и шаг табуляции: -1 1 0.2
  -1.00000       значение не существует
  -0.80000       значение не существует
  -0.60000       значение не существует
  -0.40000       значение не существует
  -0.20000       значение не существует
   0.00000       значение не существует
   0.20000       -7.93961
   0.40000       -2.16723
   0.60000       -0.74667
   0.80000       -0.21672
   1.00000        0.00000
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?