В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
дильназ152
дильназ152
23.02.2022 05:21 •  Информатика

Напишите программу на языке си. дана последовательность целых чисел и количество членов в последовательности. вычислите есть ли число 0 в поледовательности

Ответ:
WhiteRos
WhiteRos
26.08.2020 19:22
#include <stdio.h>
#include <stdlib.h>

int main() 

   int n, f=0;
   scanf ("%d", &n); 
   int a[n]; 

   srand (time(NULL));  
   for (int i = 0; i < n; i++ )  
   {
    a[i] = rand() % 20 -10;
    printf ("%4d ", a[i]);
   }
    printf("\n");
   for (int i = 0; i < n; i++ )  
    if (a[i]==0) f++;
   if (f>0) printf("YES");
   else printf("NO");
    return 0;
}

Пример:
10
-1 -4 0 1 2 5 -7 -8 5 6
YES
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?