В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Таня13151814
Таня13151814
20.09.2022 03:52 •  Информатика

есть ли 3, 6, 9 в пятизначном? дано пятизначное число. напишите программу, которая определит ответы на следующие вопросы: входит ли в данное число цифра 3? входит ли в данное число цифра 6? входит ли в данное число цифра 9? входят ли в данное число все три цифры одновременно? формат входных данных целое пятизначное положительное число (10000 ≤ n ≤ 99999) формат выходных данных 4 строки, на каждой из них ответ на соответствующий вопрос: "yes" если условие выполняется, "no" в обратном случае. примеры входные выходные данные 13690 13600

Ответ:
vbnioo
vbnioo
07.10.2020 08:43
Var a,b,i:integer; f3,f6,f9:boolean;
begin
readln(a);
f3:=false;
f6:=false;
f9:=false;
for i:=1 to 5 do
 begin
 b:=a mod 10;
 if b=3 then f3:=true;
 if b=6 then f6:=true;
 if b=9 then f9:=true;
 a:=a div 10;
 end;
if f3 then writeln('YES') else writeln('NO');
if f6 then writeln('YES') else writeln('NO');
if f9 then writeln('YES') else writeln('NO');
if f3 and f6 and f9 then writeln('YES') else writeln('NO');
end.

Пример:
13600
YES
YES
NO
NO
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?