В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ALEXANDER982
ALEXANDER982
27.10.2021 11:36 •  Информатика

Напишите программу в которой определяется сумма s всех целых чисел в интервале заданном переменами n и m а так же сумма sa четных и sb нечетных в этомже интервале

Ответ:
covo1
covo1
07.10.2020 08:33
Язык С#
код:
using System;namespace ConsoleApp95{    class Program    {        static void Main(string[] args)        {            int N, M,S = 0 ,SB = 0 ,SA = 0 ;            N = Convert.ToInt32(Console.ReadLine());            M = Convert.ToInt32(Console.ReadLine());            for ( int i = N+1; i < M; i++)            {                if ( i % 2 == 0 )                {                    S += i;                    SA += i;                }                else                {                    SB += i;                }            }            Console.WriteLine(S + "   " + SA + "  " + SB);            Console.ReadKey();        }    }}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?