В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
mcanya1
mcanya1
05.07.2020 13:56 •  Информатика

1.составьте программу которая заполняет массив a[1..30] случайными целыми числами в диапазоне от -15 до 30 и вычисляет произведение положительных элементов массива. 2. составьте программу которая заполняет массив a[1..40] случайными целыми числами в диапазоне от -20 до 10 и находит количество элементов массива кратным 3 3. составьте программу которая заполняет массив a[1..40] случайными целыми числами в диапазоне от -30 до 30 и находит среднее арифметическое отрицательных элементов массива

Ответ:
про783
про783
07.10.2020 08:09
//Pascal

//1)
var
  A: array [1..30] of integer;
  i: byte; mult: double;
begin
mult := 1;
randomize;
writeln('Сгенерированный массив.');
for i := 1 to 30 do
begin
  A[i] := random(46)-15;
  if A[i] > 0 then mult := mult * A[i];
  write(A[i], ' ');
end;
writeln;
writeln('Произведение положительных элементов = ', mult);
end.
//

//2)
var
  A: array [1..40] of integer;
  i: byte; count: byte;
begin
count := 0;
randomize;
writeln('Сгенерированный массив.');
for i := 1 to 40 do
begin
  A[i] := random(31)-20;
  if A[i] mod 3 = 0 then count := count + 1;
  write(A[i], ' ');
end;
writeln;
writeln('Количество элементов кратных трем = ', count);
end.
//

//3)
var
  A: array [1..40] of integer;
  i: byte; count: byte; sum: integer;
begin
count := 0; sum := 0;
randomize;
writeln('Сгенерированный массив.');
for i := 1 to 40 do
begin
  A[i] := random(61)-30;
  if A[i] < 0 then
  begin
    count := count + 1;
    sum := sum + A[i];
  end;
  write(A[i], ' ');
end;
writeln;
writeln('Среднее арифметическое отрицательных эл. =',(sum/count):4:4);
end.
//
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?