Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
eruder
20.05.2022 06:43 •
Информатика
Написать программу в с++, подсчитывающую количество символов в заданной строке. ответ должен быть развёрнутым.строку вводит пользователь. пример строка: мама мыла раму в строке: "мама мыла раму" символов: 14
Ответ:
Zxcvbnm900
07.10.2020 07:40
// Работает только на английском
// Количество символов для русского языка считает корректно, но вывод самой строки и работа со строкой не возможна.
#include <bits/stdc++.h>
using namespace std;
int main(){
setlocale(LC_ALL, "Russian");
char s[1000]; int ans = 0;
cin.getline(s,1000, '\n');
string s1 = string(s);
cout << "Строка: " << s << endl;
cout << "В строке: <<" << s1 << ">> ";
cout << s1.length() << " символов";
}
Пример:
For my heart
Строка: For my heart
В строке: <<For my heart>> 12 символов
0,0
(0 оценок)
Популярные вопросы: Информатика
polina17122002
22.08.2021 14:53
Гиперссылка Подпишите изображение.Как называется гиперссылка, изображённая на рисунке?...
Leroy1234567
16.06.2020 20:23
Составить список из 10 слов относящихся к теме семья...
kaiv
12.01.2020 16:31
Умова: Скласти опис класу для представлення дати. Передбачити можливість установки дати та зміни її окремих полів (день, місяць, рік) з перевіркою допустимості введених значень....
КоШкА2016
06.04.2023 03:41
Яке позначення має оператор циклу?while dodowhilewlihe do...
krop40
05.08.2022 09:13
Почему размеры созданных документов различны?...
protivnuy
30.05.2021 07:36
333333333333333333333333333333333333333333333333333333333333333333333333333333 ^^∛...
dimasikbervino
05.05.2020 11:03
Запись, A:=K+3 читается так:...
TriPPPix
18.02.2023 10:22
Вирусы. Особенности строения вирусовкак внеклеточной формы организацииЖИЗНИИз предложенного списка определи названиенауки, изучающей микроорганизмы, используянижеприведенный...
qidanabala
18.02.2023 10:22
1. Укажите слова, которые являются именами числительными. А) двойка Б) семнадцать В) пятиборье Г) пятеро 2. Укажите сложное числительное. А) восемнадцать Б) семьдесят В) двадцать...
maltsevaalbina2006
20.08.2022 07:12
Виконай ділення, використовуючи прийом укрупнення розрядних одениць 560:40960:30780:20910:70360:30920:40560:80960:60720:40720:30950:50450:30480:40360:60720:60960:80840:40570:30980:70650:50160:40...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// Количество символов для русского языка считает корректно, но вывод самой строки и работа со строкой не возможна.
#include <bits/stdc++.h>
using namespace std;
int main(){
setlocale(LC_ALL, "Russian");
char s[1000]; int ans = 0;
cin.getline(s,1000, '\n');
string s1 = string(s);
cout << "Строка: " << s << endl;
cout << "В строке: <<" << s1 << ">> ";
cout << s1.length() << " символов";
}
Пример:
For my heart
Строка: For my heart
В строке: <<For my heart>> 12 символов