Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
мдсши
22.04.2023 17:54 •
Информатика
1массив из 11 целых чисел формируется случайным образом в интервале от 5 до 45.найти сумму четных элементов массива . 2 сформировать массив из 5 целых чисел (ввод с клавиатуры ),уменьшить каждый элемент в три раза .
Ответ:
evasaidova91
07.10.2020 07:32
// PascalABC.NET 3.3, сборка 1576 от 16.11.2017
// Внимание! Если программа не работает, обновите версию!
1)
begin
var a:=ArrRandom(11,5,45).Println;
var x:= a.where(t -> t.IsEven).sum;
Writeln('Сумма четных элементов: ', x);
end.
2)
begin
var a:= ArrGen(5, t -> ReadReal).Println;
a:= a.Select(t ->t/3).ToArray.Println;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
vdhfhsbh
28.08.2022 21:23
Найти квадрат наибольшего из двух чисел а и б. вывести на экран число 1, если наибольшим является число а , число 2- если наибольшим числом является б...
ivanochka02kasik
26.12.2021 15:17
Используя оператор выбора составить программы решения следующих . составьте программу, определяющую для буквы алфавита, является ли буква гласной или нет...
05DKuzmin
15.12.2020 20:16
ВОТ ОТВЕТ НА ФОТО ОТВЕТ:ЯЧЕЙКА ПУСТАя Какой текст расположен в ячейке ВІР АB1 Магазин канцтоваров1213Магазин канцтоваровячейка пустая...
АружанкаЛав
10.09.2020 13:19
Что надо для компьютера будущего ? Составить 2-3 предложения...
ирина1834
21.06.2021 11:27
Без чего нельзя сделать сталь?...
Lika8911
25.02.2023 22:43
Ккакому типу данных относятся переменные а, b, c в операторе с : =a mod b...
aygerimorazhan
25.02.2023 22:43
Информационный объём текста, подготовленного с компьютера, равен 3 мб. 1 символ весит 1 байт. сколько символов содержит этот текст?...
Nastya45t7
16.03.2022 09:36
Нахождение связи между величиной ввп и уровнем безработицы, относится к : a)философским b) c) статистическим d) социальным...
Murua
24.02.2022 07:21
Найдите все пятизначные числа, которые при делении на 133 в остатке 125, а при делении на 134 в остатке 111. для питона...
mrtwesor
16.01.2020 10:07
Садовник вырастил 10 роз, расположив их в пять рядов, по четыре розы в каждом ряду. потом он решил вырастить двадцать пять кустов тюльпанов, расположив их в двенадцать рядов, по пять...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// Внимание! Если программа не работает, обновите версию!
1)
begin
var a:=ArrRandom(11,5,45).Println;
var x:= a.where(t -> t.IsEven).sum;
Writeln('Сумма четных элементов: ', x);
end.
2)
begin
var a:= ArrGen(5, t -> ReadReal).Println;
a:= a.Select(t ->t/3).ToArray.Println;
end.