Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
русский132
07.02.2023 08:15 •
Информатика
Написать программу в pascal, которая сортирует массив и находит количество различных чисел в нём
Ответ:
Anna3367171
07.10.2020 07:20
// PascalABC.NET 3.3, сборка 1579 от 18.11.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-10,10); a.Println;
a.Sort; a.Println;
Writeln('Кол-во разных чисел равно ',a.Distinct.Count)
end.
Пример
n= 13
-1 1 3 -2 8 -9 9 -1 -8 -8 9 -9 2
-9 -9 -8 -8 -2 -1 -1 1 2 3 8 9 9
Кол-во разных чисел равно 9
0,0
(0 оценок)
Популярные вопросы: Информатика
Kerisha4
21.02.2020 15:49
Решите в паскале: Вычислить произведение последовательности чисел от 3 до 47 с цикла с предусловием....
tyomking
21.02.2020 15:49
❤️ Какой командой можно создать новый слайд? Выбери (скопируй) правильный ответ из данного списка: Файл/Создать Файл/Сохранить Файл/Сохранить как Файл/Закрыть Файл/Открыть...
Стариат
17.05.2021 02:36
Решите 8 класс (задали не мне а сестре))...
katevina
30.03.2022 23:42
Что здесь не так? 7 строчка: форматное выражение может использоваться только внутри write, writeln и str. сама программа: program n_1; var x1, x2, y1, y2, x, y: integer;...
Жизель24
22.04.2021 03:15
Basic . напишите программу, исключающую из введенной величины все буквы а ....
iVorobey
22.04.2021 03:15
Нарисовать 50 концентрических окружностей с точкой в центре. паскаль рисует только одну окружность, вот код: uses graphabc; var r,y,x: integer; begin setwindowsize(800,600);...
Lialimur
16.08.2021 14:33
Какой объём памяти займёт ниже текст,если известно,что в нем использовалась копировочная таблица ascii? я люблю город пермь 2)с копировочной таблицы ascii закодируйте...
svetlanakomarova2
25.08.2022 21:56
Информатика 7класс. что не видно могу написать. ...
Zazej
17.12.2021 22:02
Задание Составить простой план прослушанного текста, Опираясь на составленный план, подробно перескажите прослушанный текст от 3 лица. Однажды в степях Казахстана произошло...
Girl1girl
26.03.2020 03:52
Прямые а и б параллельны. Какие высказывания являются верными, а какие - неверными? (Верные высказывания ответьте знаком + , неверные - знаком - .) А) в треугольнике...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-10,10); a.Println;
a.Sort; a.Println;
Writeln('Кол-во разных чисел равно ',a.Distinct.Count)
end.
Пример
n= 13
-1 1 3 -2 8 -9 9 -1 -8 -8 9 -9 2
-9 -9 -8 -8 -2 -1 -1 1 2 3 8 9 9
Кол-во разных чисел равно 9