Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Доминика21233
17.10.2020 05:47 •
Информатика
Написать программу подсчитивающую количество цифр целого неотрицательного числа
Ответ:
талифа4
07.10.2020 07:12
Var a,k:integer;
begin
write('a (>0) = ');
readln(a);
k:=0;
while a>0 do
begin
k:=k+1;
a:=a div 10;
end;
writeln('k = ',k);
end.
Пример:
a (>0) = 180653
k = 6
0,0
(0 оценок)
Популярные вопросы: Информатика
lida50
19.04.2023 11:34
При опросе 13 человек, каждый из которых знает по крайней мере один иностранный язык, выяснилось, что 10 человек знают язык, 7 – , 6 – испанский, 5 – и , 4 – - ский и испанский,...
Alikman123
11.10.2021 02:44
Люди нам задали проект 10 стр на любую тему но темы которые я придумал маленькие...
noxiksds
11.06.2020 21:01
718 кило-бат (кб) это много, средне, мало?...
azim20071
11.12.2021 01:00
718 кило-байт (кб) - это много, средне, мало?...
Ermolenkoo
11.12.2021 01:00
Дана квадратная матрица целых чисел. определить модуль произведения отрицательных чисел, которые находятся в нижней треугольной области матрицы: под главной и под побочной диагоналями....
Никаgyvhbbuh
26.05.2023 23:10
Даны две точки на плоскости .определите ,какая из них находится ближек началу координат...
kalashnikovale2
08.03.2021 14:51
Программа в python! пользователь вводит количество недель, месяцев, лет и получает количество дней за это время. считать, что в месяце 30 дней....
YAN222
08.02.2020 15:07
Написать программу, матрицу а размера 4х4 с вещественными элементами, вводимыми с клавиатуры ( следует вводить как положительные, так и отрицательные числа), и выполнить в соответствии...
snojkox
03.09.2021 11:12
Выберите допустимые имена файлов из перечисленных нижe a) book *.doc б book_. jpgв book.exe г ? book.jpg д book! .txt ...
mazyrin91p08sby
07.02.2022 02:27
Написать программу в паскаль турбо дан массив a размерностью n (размерность вводит пользователь). массив заполнен случайными числами от -15 до 15. каждый второй элемент заменить...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
write('a (>0) = ');
readln(a);
k:=0;
while a>0 do
begin
k:=k+1;
a:=a div 10;
end;
writeln('k = ',k);
end.
Пример:
a (>0) = 180653
k = 6