В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
vbv551
vbv551
18.11.2021 12:19 •  Информатика

Составьте программу которая формирует массив из 13 случайных чисел, от 0 до 30, меняет местами 4-й и 9-й элементы и выводит значения элементов массива на экран до и после обмена. pascal abc

Ответ:
danilnikitin624
danilnikitin624
01.09.2020 11:40
Const n=13;
var a:array[1..n] of integer;
i,c:integer;
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
 begin
 a[i]:=random(31);
 write(a[i]:4);
 end;
writeln;
c:=a[4]; a[4]:=a[9]; a[9]:=c;
for i:=1 to n do write(a[i]:4);
writeln;
end.

Пример:
Массив A:
11 25 20 0 7 28 27 26 23 25 12 24 20
11 25 20 23 7 28 27 26 0 25 12 24 20
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?