В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
oksana1410
oksana1410
13.01.2022 07:08 •  Информатика

Нужно написать программу, которая переводит число из 16-ой сс в 10-ю сс, на языке c.

Ответ:
ngazaryan
ngazaryan
07.10.2020 06:39
#include <stdio.h>

int main(void) {
int n;
printf("Введите число в 16-ричной СС: ");
scanf("%x",&n);
printf("%x(16) = %d(10)",n,n);
return 0;
}

Пример:
Введите число в 16-ричной СС: a1f
a1f(16) = 2591(10)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?