В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
loooolg
loooolg
13.12.2020 10:41 •  Информатика

Св паскале! 1) составьте программу, которая заполняет массив а [1..10] случайными целыми числами в диапазоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с чётными значениями на 1. если элементы с чётными значениями отсутствуют, оставить массив без изменений. 2) составьте программу, которая заполняет массив а [1..10] случайными целыми числами в диапазоне от 1 до 10,затем преобразовывает его, увеличивая все элементы с нечётными значениями в три раза, а элементы с чётными значениями заменяя на 0.

Ответ:
Gushkaa
Gushkaa
16.08.2020 13:54
// PascalABC.NET 3.3, сборка 1573 от 04.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(10,1,10); a.Println;
  a.Transform(t->t.IsEven?t+1:t); a.Println
end.

Пример
4 8 9 2 5 6 3 5 8 9
5 9 9 3 5 7 3 5 9 9

begin
  var a:=ArrRandom(10,1,10); a.Println;
  a.Transform(t->t.IsOdd?3*t:0); a.Println
end.

Пример
3 7 9 4 5 8 8 3 7 8
9 21 27 0 15 0 0 9 21 0
0,0(0 оценок)
Ответ:
kolyafedosov
kolyafedosov
16.08.2020 13:54
1)
var
a:array[1..10] of integer;
i:integer;
Begin
Randomize();
For i:=1 to 10 do begin
   a[i]:= 1+ random(10);
   Write(a[i], ' ');
   if a[i] mod 2 = 0 then a[i]:=a[i] + 1;
   end;
   Writeln();
For i:=1 to 10 do 
   Write(a[i], ' ');
end.

2)
var
a:array[1..10] of integer;
i:integer;
Begin
Randomize();
For i:=1 to 10 do begin
   a[i]:= 1+ random(10);
   Write(a[i], ' ');
   if a[i] mod 2 <> 0 then a[i]:=a[i] * 3 else a[i]:= 0;
   end;
   Writeln();
For i:=1 to 10 do 
   Write(a[i], ' ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?