В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
0304131
0304131
16.08.2022 09:30 •  Информатика

Дана матрица действительных чисел a размером 6х7. сформировать массив r1, …, r7, каждый элемент которого равен среднему арифметическому значению элементов соответствующего столбца матрицы a: написать программу с+,

Ответ:
ishohahdh
ishohahdh
10.08.2020 17:26
#include <iostream>
#include <iomanip>
using namespace std;

int main() {
const int n = 6, m=7;
double a[n][m];
double r[m];
double s;

srand(time(0));
for (int i = 0; i < n; i++){
 for (int j = 0; j < m; j++){
a[i][j]=-20 + (50.0 / RAND_MAX) * rand();
cout << fixed << setw (7) << setprecision (2) << a[i][j];
 }
cout <<endl;
}
for (int j = 0; j < m; j++){
 s = 0;
 for (int i = 0; i < n; i++) s+= a[i][j];
 r[j]=s/n;
 }
cout << "Полученный массив" <<endl;
for (int j = 0; j < m; j++)
cout << fixed << setw (7) << r[j];
 cout << endl;
}

Пример:
 -10.07  28.55  13.71   8.49  -4.06 -16.79  10.86
  -7.52  14.32  -5.13 -16.24  -0.26  16.80  -0.82
  11.68 -13.75   4.24  24.31   6.79 -13.02  23.65
  25.39  -8.77  -3.21  18.42  -2.37  -1.41  -9.80
  25.09  29.06 -17.98 -14.98  27.61  15.73  13.51
  -6.44  18.95  -5.63   6.03   3.27   9.24   9.79
Полученный массив
   6.35  11.39  -2.33   4.34   5.16   1.76   7.86
0,0(0 оценок)
Ответ:
evelina2023
evelina2023
10.08.2020 17:26
#include <bits/stdc++.h>
using namespace std;
int main()

{
    int a[6][7];
  for(int i = 0; i < 7; i++)
    for(int j = 0; j < 6; j++)
        scanf("%d",&a[i][j]);
    int R[7];

    for (int j = 0; j < 6; j++)
        {
            int cnt = 0;
            for (int i = 0; i < 7; i++)
                cnt += a[i][j];
            R[j] = cnt;
            cout << 'R' << j+1 << '=' << R[j] << endl;
        }
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?