Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Kotofeyka5585
05.03.2022 23:42 •
Информатика
Написать программу с++ заполнить массив двадцатью первыми натуральными числами,делящимися нацело на 13 или на 17 и находящимися в интервале,левая граница которого равна 300
Ответ:
Mraleex
07.10.2020 04:32
C++14
#include <iostream>
#define k 20
using namespace std;
int main() {
int arr[k];
bool flag = false;
for(int i = 0, l = 1; i < k; ++i){
arr[i] = l*((!flag)?13:17);
if(flag) l++;
flag = !flag;
if(arr[i] >= 300)
cout << arr[i] << " ";
else
--i;
}
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
лера1231231
04.08.2021 04:48
В матрице V(5×5) определите в каждой строке произведение отрицательных элементов.(Нужно написать код на языке , очень нужно....
leshakonovalov2
21.02.2023 21:42
Как называется программа-редактор формул,которая входит в текстовый редактор MS Word?...
eva301
10.11.2022 04:15
Написать программу на pascal использую процедуры и функции 1. вычислить сумму элементов массива, расположенных между первым и последним положительными элементами. 2. преобразовать...
masgovorchenko
19.08.2020 12:54
Как нарисовать снеговика (из трёх кругов с руками), но без глаз и носа в программе паскаль авс. !...
Koshaplay57
12.08.2021 03:02
Переведите 435(7)в Х(10) Те числа которые в скобках это системы счисления...
nikita1424
20.10.2021 20:02
Создайте программу, которая переводит секунды в минуты, часы, дни и недели. Подумайте, как для этой задачи можно было бы использовать словарь . язык програмирование python...
Koif32
09.05.2022 05:29
Расказ--почему нельзя играть с огнем...
polulera2005
09.05.2022 05:29
Сочинения мой класс цына 50 счемно пунктов...
aarchery
09.05.2022 05:29
Что делали из глины в древнем двуречье?...
Valeria20091
24.02.2023 16:58
Текст есть вот . выпиши из предложения 12 все имена существительные в той форме в которой они употреблены в предложении .укажи род склонение,число,падеж одной из форм имени существительного...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
#include <iostream>
#define k 20
using namespace std;
int main() {
int arr[k];
bool flag = false;
for(int i = 0, l = 1; i < k; ++i){
arr[i] = l*((!flag)?13:17);
if(flag) l++;
flag = !flag;
if(arr[i] >= 300)
cout << arr[i] << " ";
else
--i;
}
return 0;
}